setting up PokerTH live on my own server

Post Reply
adamtcc
Posts: 1
Joined: Fri Apr 30, 2021 4:38 am

I went to the github page for PokerTH live and followed the instructions to install it on my ubuntu server but I can not get it to work.

I'm not even sure I understand the concept correctly. I have a different ubuntu server running pokerth-server and that works, we can connect to it over the internet and play pokerth together.

I thought installing PokerTH Live and serving it as a webpage on a different machine on my LAN would make the live spectator feature work on the ubuntu server running apache, but first I was getting object error whenever I logged in as a guest, then after adjusting the ports to match in the config.xml file on the pokerth server and fixing the LAN IP in the ./inc/pokerth-live_min.js and ./inc/net/neteventhandler.js on the pokerth-live server I finally got the error message to change to "invalid server" but I can't get any further and I don't really understand websockets and the readme file is too basic for me.

can anyone help?
Thanks,
User avatar
sp0ck
Posts: 89
Joined: Mon Mar 15, 2021 12:54 pm

adamtcc wrote: Fri Apr 30, 2021 4:47 am I went to the github page for PokerTH live and followed the instructions to install it on my ubuntu server but I can not get it to work.

I'm not even sure I understand the concept correctly. I have a different ubuntu server running pokerth-server and that works, we can connect to it over the internet and play pokerth together.

I thought installing PokerTH Live and serving it as a webpage on a different machine on my LAN would make the live spectator feature work on the ubuntu server running apache, but first I was getting object error whenever I logged in as a guest, then after adjusting the ports to match in the config.xml file on the pokerth server and fixing the LAN IP in the ./inc/pokerth-live_min.js and ./inc/net/neteventhandler.js on the pokerth-live server I finally got the error message to change to "invalid server" but I can't get any further and I don't really understand websockets and the readme file is too basic for me.

can anyone help?
Thanks,
Hi adamtcc,

sorry for late reply - I'm not at home these days, and my access to the internet is currently limited.

Please check following entries in config.xml:

Code: Select all

        <ServerUseWebSocket value="1" />
        <ServerWebSocketPort value="7233" />
        <ServerWebSocketResource value="" />
        <ServerWebSocketOrigin value="" />
Origin is the uri - e.g. /blahfasel (if I'm not wrong now - I did not yet have time to setup our own spec tool).

Try a telnet directly from the server - e.g. telnet localhost 7233 - in order to check if the websocket server is running at all.

Let me know if that works for you.

Regards,
sp0ck


EDIT: Spectator Tool works without ssl only - so it must be ws://
Post Reply