Page 1 of 1

Compile pokerTH on Debian 8 doesnt work

Posted: Wed Jan 11, 2023 6:01 pm
by sam289
Hello
I try to compile pokerTH on Debian 8 and stuck at
libgcrypt library.

apt-get install libgcrypt... --> doesn't work

Download libgcrypt and compiling cause error
libgpg-error missing

Then download libgpg-error ... compiling successfull.

Try again compiling libgcrypt with parameter where libgpg-error is.
--> doesn't work cant find lib

Anybody here has knowledge to solve this problem ?

Re: Compile pokerTH on Debian 8 doesnt work

Posted: Thu Jan 12, 2023 6:17 am
by sp0ck

Code: Select all

apt build-dep pokerth

Code: Select all

apt install libmysql++-dev qt5-default
... these commands do the trick on Ubuntu 18.04 - the package names for Debian might be slightly different in the second command.

Please also checkout Github Wiki.

Re: Compile pokerTH on Debian 8 doesnt work

Posted: Thu Jan 12, 2023 3:02 pm
by sam289
Hi, thank you. :-)

The used HDD crashed now and I have to install Debian on other HDD, USB Stick and then I try your recommendations. Debian Gnome crashed, freezed.